Trading Thresholds exceeded
Author: digitalsculpture
Creation Date: 8/3/2020 4:12 PM
profile picture


This morning I began live trading. I'm using a position size of $1,000, and a scale of 30 minutes.

While getting started, I wanted to only have $7,000 of my capital in positions at one time, so seven $1000 positions. In trading preferences, I enabled the cash threshold and set it to an amount that I thought would impose this limit. However, when the market opened, I suddenly had $20,000 in new positions.

After closing out all of the initial positions, I worked to find a solution to this issue on my own. In the WLD user guide I read the following:

"Warning! Thresholds will not inhibit simultaneously-placed orders. .... Example .... Assume current Buying Power (BP) is $30K and $10K BP Threshold is enabled. If the Orders tool receives two $25K orders simultaneously (on the same bar), both orders can be placed since buying power is sufficient to cover each trade individually."

With this warning in mind, I thought that my problem could be solved by using the position sizer to limit the number of entries per bar. So, I used the position sizer and set it to "max entries per day (bar)", with a limit of 2. My reasoning was that these settings would make it so that only two limit orders would be autoplaced every 30 minutes.

While adding the strategy, I encountered this popup message: "You have selected a portfolio simulation position sizing mode. This might lead to inconsistent trade alerts. Raw profit position size mode is recommended in the strategy monitor".

I went ahead and activated the strategy anyway to see what would happen, and at 12:00 over ten orders were placed. So I guess this isn't a correct solution.

Anyhow, again, what I'm trying to do is only have seven $1,000 positions at one time. Any input you can offer about how to make this happen would be much appreciated.

profile picture


Thresholds should work generally but as you've correctly figured out, not for simultaneous trades (being placed on the same bar).

"Max Entries Per Day" concerns the single 30-minute bar only. The Position Options PosSizer has an advanced option designed to really cap maximum entries per day for intraday strategies by summing up the positions they take during the day. It's part of our MS123 PosSizers extension.
profile picture


Thanks. I've downloaded and installed the extension. There are a lot of options now.

I've read through the documentation at:

I'm still not sure how to achieve the exact result I'm after.

Can you give me some additional guidance on how I can impose these constraints?:
- Limit to seven $1000 positions at a time
- Only one position per symbol

profile picture


Should I click on "position options" and then use the settings in the attached image?

Again, one of the key things I'm trying to do is to keep from entering more than seven $1000 positions at a time. I thought I could get this result by setting "max pos. per day" to 2, because I thought that here "day" refers to the day OR bar on the chart. When backtesting these settings I see that I'm only entering two trades per day.

So, how can I limit to just seven $1000 positions at a time using a 30 minute chart?
profile picture


Well, yes - your settings look correct. But it doesn't discard what's said in the User Guide > Strategy Monitor re: "Operational difference between the Strategy Monitor and Backtester". Meaning that I'm not making any promises.
profile picture


I read over the "operational differences between the strategy monitor and backtester", and I understand that using these position sizer settings for live trading is at my own risk.

I went ahead and opened the strategy monitor, added my strategy, and used the following settings for "position options":
- fixed dollar: $1000
- max invested: $7000
- max open positions: 7
- max open in symbol: 1

I eliminated the max pos. per day of 2 because, after reading over the documentation for the position sizer I understood (maybe incorrectly) that this would limit my *total* new positions in a day to 2. Again, what I'm trying to do is limit to holding just seven $1000 positions at once.

I activated the strategy, and at 1:30 the strategy monitor sent approximately 15 limit orders to the orders panel. I canceled all of the orders in order to avoid exceeding the $7000 limit I'm trying to work within.

So, what am I doing wrong?
profile picture


Actually, you're not doing anything wrong but there are certain limitations:

1. "Max open [positions] in a symbol" is not compatible with Alerts by design.
2. "Max Open Positions" is broken in WLD 6.9.23. This is a long-standing bug WL that affects PosSizers and should finally get fixed by 6.9.24. This works for backtests but not for Alerts at the moment.
profile picture


Okay, thanks for clearing that up for me. Are there any workaround solutions that I could try to get the same result I'm after?
profile picture


A workaround could probably be approached in WealthScript using code like this: Only one symbol at a time but multiple positions (post #8). So it'd take a rewrite of your script for it to run in single-symbol mode. This and next week I surely will not have any time to dedicate to this as we've been occupied with various transition-related and development tasks.
profile picture


There aren't any good ways with Wealth Lab to limit the number of positions. It only works in back testing and not in real life. The only way is to limit the number of stocks you screen to the number of trades you want but then you limit potential trades to only those symbols.

It's a huge limitation of live trading with the platform. I've been through the gambit with Fidelity and their active traders to try and figure out options but no luck. I've asked here as well but there isn't an answer that actually works with live trading if using intraday alerts.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).