"The request failed with an empty response" error when downloading public Strategies
Author: ReneW
Creation Date: 9/1/2019 1:21 PM
profile picture



once in a while I want to see what others are doing
and I wanted to download public strategies.
I wanted to follow Eugenes Tip in the Wiki, I cite:
"TASC 2019-10 | Combining Bollinger Bands With Candlesticks (Kosinski)...

Since it has some prerequisites, it’s preferred that you simply download this code in Wealth-Lab (hit Ctrl-O and choose "Download...") rather than copy/paste it: "

Surprisingly, that failed...
WL is installed on a network server.

Any ideas ?

Btw, network is ok.

profile picture


Hi Rene,

This error may be caused by hitting HTTP for Strategy downloads whereas our website has switched to HTTPS:

Looking at the software authentication logs, you're using an outdated revision of 6.9.15 build which used exactly HTTP. (As your WLD license keys expired years ago, you must also be doing it from a different customer's account which causes some confusion.) So please update your Wealth-Lab Dev installation by uninstalling it, downloading the latest version from our website, and reinstalling. Because certain Wealth-Lab Extensions will be removed upon uninstallation you'll have to reinstall them, too. If you have concerns see this FAQ: How do I upgrade Wealth-Lab Developer to a new build?

Assuming that everything works you should see something like this (since I've got all of them no new strategies were added):

P.S. As "Downloading Public Strategies" did not summarize the problem well enough I've renamed your topic. Now it can be found by forum search.

P.P.S. Hint: You should really stick with PNG as JPG is truly suboptimal for screenshots. If you haven't seen this famous comics, it's perfect time :)

JPEG or PNG – Which Image Format Offers Better Quality?
profile picture


Sorry Eugene...

1.) WL tells me on startup, it is up-to-date
2.) Any download link leads to my current version...
3.) License ... I will open a support ticket for that

Yours, Rene
profile picture



Please just take the steps exactly as instructed above. Despite the same version number (6.9.15) there are internal differences. I know what I'm talking about when saying that your installation may be out of date.
profile picture


Okay, then I am a little disgusted about the missing timely update notification.
profile picture


I'm not sure that this should fix it for you. For now let's just consider this a working hypothesis. Maybe it's as simple as a network issue on your end (firewall misconfiguration, antivirus etc.) but I'd start with WLD upgrade as the natural step.
profile picture


Solution: Reinstall a fresh WLD download over the existing installation, _SAME_ version according to the version number.

Re-installed MS123 visualizer ... because of an error in backtests, althought it said: "All extensions are up to date".

At first sight, now all seems to be working, downloads, backtests.
And the mentioned download of the public strategies now worked as well.

Thank you Eugene, problem solved, with some thinking about version numbers.
Please go over the support ticket... and decide about my licenses.
profile picture


The version number in Help > About is not indicative of all subtle changes to the various components and subsystems.

Glad to help you Rene.
profile picture


On a related note:

When encountered during installation of Extensions by a Developer (WLD) customer running v6.9.15 and lower, the same error message "The request failed with an empty response" in the Extension Manager indicates that WLD must be reinstalled from scratch. See my post #2 above for explanation and for a step-by-step procedure look here:

Errors installing/updating Extensions > Solution #2
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).