Stooq static data provider
Author: Eugene
Creation Date: 9/27/2014 3:41 AM
profile picture


Just released: Stooq static data provider. With its help, Wealth-Lab users can download daily (EOD) historical price data for world stocks, futures and indices from Stooq website.

The provider is available for installation from our web site (Extensions section):

Stooq provider - installation link

Please read the online setup guide before using:

Stooq provider online notes in the Wealth-Lab Wiki
profile picture


What's new in v2016.10?

* Fix: data not downloaded in certain locales. This release is a must have for international customers.
* Fix: removed artificial limit (by default) in New DataSet Wizard preventing from creating DataSets which contain more than ~6500 symbols (32767 chars)
* Change: .NET 4.5 and WL 6.8+ are required to install/update extension
profile picture


Thanks Eugene. I just downloaded and I run. I got the messages below (as example)
Invalid symbol: 10CAY.B No data available
Invalid symbol: 10DEY.B No data available
Invalid symbol: 10JPY.B No data available
Invalid symbol: 10USY.B No data available
Invalid symbol: 10UKY.B No data available
Invalid symbol: 2USY.B No data available
Invalid symbol: 30USY.B No data available
Invalid symbol: AUDJPY No data available
Invalid symbol: AUDUSD No data available

did they change the symbols? something wrong from my side or something to change?
thanks for your help
profile picture


Just double checked with different operating system languages, the same symbols (and some others I tried) work for me:


Updating DataSet Stooq(Daily) ...
Up-to-date symbols: 0, Update required for: 0, New symbols: 3
Updating new symbols...
Symbol: AAPL.US Bars: 8095, Last date: 10/18/2016
Symbol: 30USY.B Bars: 9918, Last date: 10/18/2016
Symbol: AUDUSD Bars: 11747, Last date: 10/18/2016
Update completed (1.512 sec)


There's also a hit limit at Stooq which results in an error once triggered. But unless they've changed something in this case you'd rather face a "daily download quota exceeded" message than "invalid symbol". I have no idea, please retry later and/or from a different PC.
profile picture


I uninstalled and erased all folders with name Stooq and run again. Same issue. I tried it in another PC and got same result. I use in both Windows 10. any clue how to solve it? tks.
profile picture


This error message can indicate only two things: either the raw data file requested from Stooq contains a "No data" string or it's empty altogether. This is specific to your environment, it's not the provider's fault. For example, this could happen due to network settings (your firewall, Internet Explorer configuration...) or if your IP were blacklisted at Stooq (less likely). Besides that I have no other insights.
profile picture


What's new in v2017.04:

* Fix: "Update all data" doesn't update any data during first-time update
* Change: Wealth-Lab 6.9+ required to install/update
profile picture


What's new in v2017.09:

* Fix: no data for indices (URI change @ Stooq)
* Fix: removed a timeout which may prevent loading symbols with large history with "No data available"
* Change: (internal) upgraded browser user-agent; switched client to HTTPS
profile picture


* Fix: no data for indices (URI change @ Stooq)

Can't say I'm happy with the fix. It causes a bigger problem: unnecessary data refreshes on each update. If you request many symbols it's a matter of time when your IP gets blacklisted by Stooq for a while (when you constantly get an error message on data update).

In a hotfix soon to be released, I'm going to revert this behavior (download entire history). To honor Jinye's request, exception will be made for indexes (which start with a ^). As this is the only way to get their entire data and not receive a "No Data" error, their history will be reloaded from scratch.

Also there will be other improvements.
profile picture


What's new in version 2017.10:

* New: support for automatic bar data corrections
* New: option to apply .US suffix to symbols in New DataSet Wizard for convenience (if they're all U.S. symbols)
* Fix: recent "No Data" fix caused refreshing all data on each request. Now it applies to indexes (which start with ^) exclusively
profile picture


Stooq not updating


Updating Provider Stooq ...
Daily data is being updated...

Up-to-date symbols: 0, Update required for: 23, New symbols: 0
Error: The added or subtracted value results in an un-representable DateTime.
Parameter name: value

Provider update complete for Stooq
profile picture


Here's workaround to the issue:

Errors | Data > Error while updating Yahoo! data: (un-representable DateTime)

Scroll down to the bottom and substitute YahooStaticProvider with StooqProvider.

We'll fix this annoyance across existing static data providers (including Stooq) in v2018.12 (ETA end of November). Thanks for the heads-up.
profile picture



I hope that the error you reported in #11 (The added or subtracted value results in an un-representable DateTime) is now fixed. Please update the extension to v2018.12 and restart WLP to apply.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).